Overview: The Map Window

The MFworks Map window is a powerful facility for the visualization and manipulation of map layer data. It permits you to view each data point individually or in context with all the other data points. The Map window is the focal point for all the other windows associated with the map layer: the Legend window, the Information window, the Comment window, and the Layout window. Actions performed in an associated window can affect the appearance and characteristics of the Map window and vice versa. The Map window comes with a set of tools and controls that give you the ability to mark, measure, view, and alter the appearance of the map layer and change its underlying data.
The name of the map layer appears on the left side of the title bar on the top of the Map window. The tools and visualization controls appear around the outside of the Map window. The scroll bars on the right-hand side and bottom of the window permit you to scroll the map if it is larger than the Map window's field of view. The Map window can be moved around the desktop and resized.

The Map Menu

The Map window has its own menu in the menu bar when it is the active window. The Map menu allows you to show or hide several features of the Map window. It contains zoom commands which can be used when the Map window tools are hidden. It permits you to add active map layers to the open project. It has options to switch the rulers to display a user defined coordinate system and define or update a coordinate system. And, it has an option that allows you to dither the Map window colours to compensate for monitors with limited colour display capabilities. The settings chosen from the Map menu apply only to the active Map window.

Rulers

Rulers are graduated scales which, when selected, are displayed on the top and left-hand sides of the map. The rulers can be set to display the pointer position by row and column number, distance from the point (0,0), or a user defined coordinate system. Rulers display the position of the pointer as it
moves over the map by two sliding triangles. The triangles track the horizontal and vertical movement of the pointer relative to the rulers.

Use the **Show Rulers** or **Hide Rulers** options from the **Map** menu to turn the rulers on or off.

**Tracker** Use the **Tracker** option from the **Map** menu to turn the numeric display of the pointer tracker on or off.

The tracker displays four different numeric items along the bottom of the map window, below the scroll bar. The first two numbers, beside the vertical and horizontal arrows, are the coordinates of the cell over which the pointer is passing. When the rulers are set to display in distances, the tracker gives position as distance from the point (0,0). When the rulers are set to
display in a user defined coordinate system, the tracker will give position in either Latitude and Longitude, or in UTM metres.

The number beside the diagonal arrow is the pointer’s distance from a selected cell. If more than one cell is selected, then the top left-hand corner cell of the selection is the cell from which distance is measured. Distance is given in number of cell units, the number of data units (i.e., mm, cm, m, or km), or the number of real world units depending on which ruler you select. Distance is measured from the centre of the specified cell to the centre of the cell over which the pointer is passing.

The next pair of numbers are related to the azimuth of the map. The first number is the bearing in degrees from the centre of the selected cell, or top left-hand corner cell if more than one cell is selected, to the centre of the cell over which the pointer is passing. The second number, in brackets, is the
back bearing from the cell over which the pointer is passing to the specified cell.

**Tools** The Tools menu option allows you to turn the tool box on or off. Turning the tool box off affords a wider display area.

To maximize the size of the Map window, turn off the tools, rulers, and tracker and expand the Map window to fill the entire screen adjust the magnification of the view using the Zoom controls in the Map menu to set the map size to fit in the full screen window. Choose the tool to be used next on the map before hiding the tools, otherwise Show Tools will have to be used again to select the tool.

**Add to project** To add a map layer reference that has been removed from a project map layer reference list back to the list, use the Add to Project option in the Map menu. When a map is opened or created, it is added automatically to
the reference list of the open project. To make the addition permanent, save the project before closing it.

If a map layer has not been added to the open project, it cannot be used in a script. Attempting to do so will cause the following error message to be displayed:

```
Error: unrecognized map name "b".
```

### Map Window Tools and Controls

The tool box located in the top left-hand corner of the Map window contains the tools and controls necessary to select portions of the map, view the data values of selected cells, change the value of cells by “drawing” on a map, alter the magnification of the Map window, and redraw the window.

![Map Window Tools and Controls](image)

The tool box can be hidden to make a greater area of screen available for the map display. Use the Tools option in the Map menu to do this.

**Selection tool** The selection tool is used to select a cell, or rectangle of cells, in the Map window. Clicking on a single cell with the selection tool will highlight that cell with a marquee. When a single cell is selected, the drawing colour and
value in the bottom left-hand corner of the Map window change to reflect the value and colour of the cell.

To select more than one cell, click and drag a marquee to encompass the cells to be specified. When more than one cell is selected, the drawing colour and value in the bottom left-hand corner of the Map window will remain unchanged. To change a selection after it has initially been set, use shift-click to increase or decrease the marquee to the pointer position.

The selection tool can be used in conjunction with the rulers and the trackers to measure distance and direction from specified cells. It can also be used to select portions of the map for editing.

The selection tool can be used to direct the zoom commands. Selected cells always remain in the centre of the Map window when zooming in or out. This is useful for viewing a map and then focusing in on a particular place. Simply click on a cell in the centre of the area of interest and zoom in using the zoom controls from the tool box or the zoom commands from the Map menu.
The selection tool can be used with the redraw button to redraw only the area within the selection marquee.

The selection tool can be used to set the drawing colour and value it is also used to specify an area to be placed in the Clipboard, or to specify the position on the map where cells from the Clipboard are to be pasted.

**Numeric magnifying glass**

The numeric magnifying glass is a tool to view the actual values in cells. To use the magnifying glass, click on the magnifying glass button at the top right-hand corner of the tool box. Move the pointer over the map area and the pointer will change from an arrow to a magnifying glass.

Move the pointer so that the cell, or cells, of interest are centred under the magnifying glass, then press and hold down the mouse button. Doing this
brings up a 5 cell by 5 cell matrix displaying the values and colours of the
cells that are centred under the pointer.

Move the pointer with the mouse button depressed and the matrix will move
with it and change to reflect the new values surrounding the centre cell. If
the pointer is moved beyond the edge of the Map window, the map will
scroll until the last row or column is reached. The matrix is not visible when
the map is scrolling.

**Drawing tools**
The drawing tools are grouped together below the selection tool and the
magnifying glass. Please refer to [Map Drawing Tools](#), for a complete
discussion of the drawing tools.

There are four drawing tools:

**The Pencil tool**
The Pencil tool is used for marking one cell at a time or for freehand
drawing.

**The Line tool**
The Line tool is used for drawing straight segments between two points.
The Polygon tool
The Polygon tool is used for drawing a sequence of connected straight line segments (open polygons) between two points or for creating closed, filled polygons.

The Paint Can tool
The Paint Can tool is used for filling areas that contain identical adjacent values.

Zoom controls
The zoom controls affect the magnification at which the map in the Map window is viewed. The zoom controls set the Map window magnification as a cell-to-pixel ratio. The Map window zoom can be adjusted from two places: the tool box, and the Map menu.

The Map window magnification can be set in two ways using the zoom controls in the tool box. The first is by clicking on the zoom out or zoom in buttons. Pressing zoom out reduces the magnification by 50% pressing zoom in increases the magnification by 200%. The change in zoom is reflected automatically on the zoom ratio button display.
The second way to adjust the magnification using the zoom controls is to click and hold the zoom ratio button. Clicking on this button causes the zoom ratio drop-down list to be displayed.

To adjust the magnification select a zoom ratio from the menu. A zoom ratio of 2:1 reduces magnification by 50% from a 1:1 ratio. In other words, there are two cells in each axis direction (four cells all together) represented by each pixel on the screen. A zoom ratio of 1:2 increases magnification by 200% from a 1:1 ratio. In other words, there is one cell for every two pixels in each axis direction (four pixels per cell) on the screen. Magnification can go from a minimum of 32:1 to a maximum of 1:32.

These same capabilities are available from the Map menu. Use the zoom commands in the Map menu when the tool box is hidden.
Instead of buttons, the Map menu has **Zoom out** and **Zoom in** commands, and a **Zoom ratio** submenu. Magnification can be set in increments based on powers of 2 from 32:1 to 1:32.

**Note:** drawing tools do not function below a ratio of 1:1.

**Redraw tool**
Redraw is used when the Map window, or a portion of the Map window, needs to be redrawn. The ESC key is used to halt the redrawing process. The only time this button is likely to be used is when the map is very large and is being viewed at a high zoom ratio (e.g., 32:1) or when only a small part of the map is to be viewed.

To view only a small portion of the map, click on the stop button to halt the redrawing process, use the selection tool to specify the area to be viewed, then click on redraw button only the selected area will redraw.

**Drawing colour and value**
The current drawing colour and value are displayed in the bottom left-hand corner of the Map window. When a map layer is opened, the drawing colour and value fields in the bottom left-hand corner of the Map window will reflect the colour and value of the first legend entry.

**Map Drawing Tools**
The Map window tool box comes equipped with four different drawing tools that can be used to modify a map by marking, tracing, erasing, filling,
or editing single cells or groups of cells. These tools will alter the value and colour of the cell(s) to which they are applied.

The tools can be used to perform many functions, including:

- to mark the locations of objects or places on a basemap
- to trace over the scan of an existing map such as a topographic map
- to trace features on satellite images and scans of airphotos
- to remove or change erroneous values on a map
- to change uniformly the value of a single polygon.

Note: the drawing tools do not function below a magnification ratio of 1:1.

Before the drawing tools can be used, the drawing colour and value must be set. The coloured rectangle at the bottom left-hand corner of the Map window indicates the current drawing colour and the adjacent number is the current drawing value.

Setting the drawing colour
The drawing colour can be set either before or after the drawing value is set. One way that you can set the drawing colour is to press and hold the mouse button down on the drawing colour field, located in the bottom left-hand corner of the Map window. First, set the Map window zoom ratio to 1:1 or higher, then select a drawing tool by clicking on it with the pointer. Next,
press and hold on the drawing colour field to display the colour palette drop-down list. Choose a colour from the menu, or select Other to open the Colour Picker dialog box.
If the Other option is selected, the Colour Picker dialog box will open in either RGB, CMY, or HSL mode, depending on what colour model was used last (RGB is the default).

![Colour Picker dialog box]

If you are most comfortable choosing colours from the standard Windows System Colours, click on the System button to set the drawing colour. To switch between colour models, click on the Model drop-down list and select the colour model to be used.

![Colour Picker dialog box]

Use the Colour Picker to select the colour (refer to the Legend Window document), then click on the OK button. By default, the drawing value will be set to the last value found in the map layer data set plus one. For example, if the last value in the data set is 14, then the drawing value will be set to 15.
Refer to **Setting the drawing value**, below, to find out how to change this value.

**Setting the drawing value**
The drawing value can be set before or after setting the drawing colour. Select a drawing tool, then click on the value field with the pointer. When the existing value is highlighted, type in the new drawing value.

![Highlight the drawing value and type in a new value](image)

If the drawing colour is not set, MFworks will assign a random colour automatically. If a value is entered that already exists in the map layer data set, then the colour for that value will be used automatically.

**Using the selection tool to draw with existing colours and values**
To draw with a colour and value that already exists in the map, use the selection tool to click on a cell that is the required colour and value. Doing
this will automatically set the drawing colour and value display to reflect the colour and value of the selected cell.

Click on a cell to copy its drawing colour and value

With the drawing colour and value set, click on a drawing tool and start drawing.

Another way to set the drawing colour and value to an existing colour and value is to make the Legend window the active window, then click on the legend entry with the required colour and value. To use this method only one legend entry can be selected at a time. If more than one legend entry is
highlighted, the first legend entry selected will become the drawing colour and value.

![Legend window](image)

The drawing tool can be selected either before or after setting the drawing colour and value if the colour and value are set from the Legend window.

**Pencil tool**  
The pencil tool is a freehand drawing tool that can be used to change the colour and value of a single cell or group of cells. To mark a single cell, set the drawing colour and value, then click on the cell in the map to be changed with the pencil tool. The specified cell will be assigned the new colour and value.

![Pencil tool](image)

The pencil tool is the ideal drawing tool for tracing complicated shapes such as rivers and rock outcrops where there are very few long, straight lines. To use the pencil tool continuously, click at the start point of the outline and hold down the mouse button slowly drag the tool along the outline. Each cell
that the tool passes over will be changed to the new colour and value and the Legend window will be updated automatically to reflect the change.

If the pencil tool is dragged beyond the visible cell area, the Map window will scroll.

To restrict the pencil tool to drawing vertical and horizontal lines only, press the **Shift** key before clicking and dragging.

**Hint:** Set the mouse tracking (speed) to the slowest setting when tracing complicated shapes. This will permit finer control of the pencil tool. To
change the mouse tracking, open the **Mouse Properties** control panel in the **Control Panels** folder.
**Line tool**  The line tool is used to mark straight lines between two points. Set the drawing colour and value, then click on the point where the line is to begin. This point is called the anchor point.

Hold down the mouse button and drag the line out from the anchor point to the end point. The line will move with the tool from the anchor point until the mouse button is released. Carefully position the tool over the end point, check to be sure that the line is positioned correctly, then release the button.

To constrain the angle at which the line is drawn, hold down the Shift key while drawing. This will limit the line to be drawn to 45° increments from the vertical (i.e., 0°, 45°, 90°, 135°, etc.).

If the line is dragged beyond the visible cell area, the Map window will scroll.

**Polygon tool**  The polygon tool can be used in two ways: to draw an open polygon, and to draw a closed, filled polygon. In both cases, set the drawing colour and value, then start drawing.
Using the Polygon Tool to Draw Open Polygons

The polygon tool works better than the line tool for tracing fairly complex outlines because it allows continuous drawing. A new line does not have to be started for each line segment.

The polygon tool is ideal for tracing the course of a winding road or the meanders and turns of a river network — any continuous path that is made up of multiple segments.

As with the line tool, the angle that each line segment is drawn at can be constrained by holding down the Shift key while dragging out the line segment from the anchor point. This limits the segment to be drawn to 45° increments from the vertical (i.e., 0°, 45°, 90°, 135°, etc.).

To use the polygon tool, click and release the mouse button at the start and end points of each line segment. Click each time a segment ends and a new anchor point will be placed from which the next segment can be drawn. A line will track from the new anchor point and follow the pointer until the next point is placed by clicking.

To complete the open polygon, double click as the last anchor point is placed.

Using the Polygon Tool to Draw Closed Polygons

The polygon tool can also be used to outline and fill regular and irregular shaped areas. To trace the outline of the polygon use the same click and move technique outlined above.
To draw a closed polygon, click on the first point so that the first and last point are the same. When the polygon tool is moved to within three cells of the first anchor point the line segment will automatically “snap” to the point. To close the polygon, click the mouse button. The closed polygon will fill automatically with the specified drawing colour and value.

Paint can tool

This tool is used to change the colour and value of an existing uniform area of cells with identical values. The cells to be changed must be in contact with each other either horizontally or vertically. Diagonally adjacent cells of the same value will not be affected by applying the paint can tool. This process is known as filling. A fill can be applied to an object that has been outlined with the pencil tool, the line tool, or the polygon tool.

The paint can tool works by checking the cell values that are horizontally or vertically adjacent to the first cell that was clicked on. If the values are the same, the cell will be assigned the new value; if they are different, the cell value will remain unchanged. Picture a flood of paint spilling out from the first cell into all the horizontally and vertically connected cells with the same value as the first cell. Each cell with a value that is different from the first cell repels the paint and remains unchanged. The paint continues to
flow until no more horizontally and vertically connected same-value cells are encountered.

To use the paint can tool, position the very end of the drop of paint that appears to be pouring from the paint can over the first cell to be filled and click the mouse button.
The fill operation can take a long time to perform, especially if the map is large. The routine checks the whole map for "leaks" where the paint might spill out into adjacent cells.

Use **Shift**-click with the paint can tool to constrain the fill to the current window view. First make sure that there are no cells outside the current view that should be included in the fill, then hold down the **Shift** key and click the mouse button on the cell where the fill is to start.

Only similar horizontally and vertically adjacent cells within the visible Map window will be filled. This technique also allows you to employ the edge of the Map window as a "fence" to block the flow of paint.

**Clipboard Commands**

MFworks supports all the standard **Clipboard** editing commands. You can **Cut**, **Copy**, and **Paste** to and from the **Clipboard** facility. Cut, copy, and paste can be performed either on the same map layer or from one map layer to another. Individual map layers can be edited, sections of one map layer
can be pasted onto another, a new map layer can be created from a subscene of an existing map layer or a mosaic of several map layers together.

To perform **Clipboard** commands on a map, the Map window must be open and active.

**Selection tool**  Before using the **Cut** and **Copy** commands, use the selection tool to select the cell or cells to be acted on.

Use the pointer to choose the selection tool from the top left-hand corner of the Map window tool box.

The selection tool can be used to select a cell or a rectangle of cells from the map in the Map window. When the selection tool is passed over the map viewing area it becomes a cross-hair the cell beneath the dot in the centre of the cross-hair defines the position of the selection tool relative to the origin. Its position can be determined using the **rulers and tracker**.

To select a single cell, centre the selection tool over the cell and click on it. To select a range of cells, click on one of the corners of the rectangle that
will define the area to be selected, hold down the mouse button, then drag the marquee from the anchor point to encompass the desired selection area.

Release the mouse button and the marquee will remain in position. Clicking anywhere on the map will de-select the specified area and will cause a new cell or cell area to be selected.

To resize or reshape the marquee, hold down the **Shift** key and click near the corner of the marquee to be adjusted. The corner of the marquee will snap to the specified position. Resize and reshape the marquee by pressing **Shift**-click and holding down the mouse button. To define the new selection reposition the mouse then release the mouse button.

**Cutting** To cut, use the selection marquee to define the cell or cell area to be cut from the map, then choose **Cut** from the **Edit** menu. The selected cell or cells will be placed in the **Clipboard** and their values and colours in the map will be
replaced by the value “VOID” (“VOID” is a special value that is considered the absence of a value).

If the value “VOID” does not already exist in the data with some other colour, then the cells will be coloured white.

**Copying** To copy, use the selection marquee to define the cell or cell area to be copied from the map, then choose **Copy** from the **Edit** menu. A copy of the selected cell or cells will be placed in the **Clipboard** the selected cells on the map remain unaltered.

**Pasting** The **Paste** command is in the **Edit** menu. When you use the **Paste** command, the contents of the **Clipboard** are pasted onto the active **Map window** at the position of a selected cell. If more than one cell is selected at the paste position, the paste will begin from the top left-hand corner of the
marquee and continue until the full contents of the **Clipboard** are pasted onto the map. Only map fragments can be pasted onto a map text and objects cannot be pasted from the **Clipboard** into a Map window.

The size of the cell area that is pasted onto the receiving map cannot be constrained by the selection marquee. Whatever is in the **Clipboard** will be pasted onto the receiving map beginning at the selected cell position and will replace the equivalent number of cells in the receiving map. In other words, if the selection marquee on the receiving map defines a 5 cell by 5 cell area, but a 10 cell by 10 cell area was placed into the **Clipboard** from the source map, then a 10 cell by 10 cell area will be pasted onto the receiving map.

If the area being pasted from the **Clipboard** is too large to fit onto the receiving map, then MFworks will fit as much as it can onto the map and will crop the excess cells at the edge of the map. The paste always starts
from the top left-hand corner of the selection and matches it to the top left-hand corner of the area in the **Clipboard**.

1. Select and copy cell area to clipboard

2. Select paste position by clicking on a cell

3. Paste the contents of the clipboard

The colours of the cells in the area being pasted from the **Clipboard** are recoloured to reflect the colour scheme of the receiving map layer if there are identical values in the source map layer and the receiving map layer.

There are some restrictions on what can be pasted to a Map window. If the **Clipboard** contents were not cut or copied from a MFworks Map window, the contents cannot be pasted into the Map window. The source and receiving map layers must be of the same data type (floating point or fixed point) however, they do not have to have the same origin, cell resolution, data units, or azimuth. A MFworks map layer can be pasted to other applications. The map fragment will become a EMF graphic in other applications.
If a cell position is not defined with the selection tool in the receiving Map window, MFworks will locate the paste position based on the cell coordinates of the paste area and the receiving map layer. In this case, the coordinates of the cells being pasted must be coincidental with those of the receiving map layer or the following error message will be posted:

![Error Message]

Pasting does not clear the contents of the **Clipboard**. It is possible to paste the same selection several times. The selection will be lost under the following circumstances:

- If something new is copied into the **Clipboard**
- MFworks is **quit and restarted**
- The computer is shut down.

**Paste to new map**

The **Clipboard** commands can be used to create a new map layer that is a subscene of the source map layer. The new map layer will have the same characteristics as the source map layer including the same data type, azimuth, cell resolution, data units, and colour scheme for those zones.
contained within the subscene. The origin and number of rows and columns of the new map layer will depend on the origin and size of the selection.

After cutting or copying a selection from the source map layer, choose Paste To New Map from the Edit menu. A new map layer will be created and added to the open project. Save the map layer to make it permanent.

**Clearing** Use Clear to change all the cells within the selection marquee to the value “VOID”. From the Edit menu, choose Clear. Nothing is copied to the Clipboard.

**Selecting all** Select All is a shortcut command when you want to perform an editing command on the whole map layer. For example, the whole map layer can be copied to the Clipboard and then pasted into a map mosaic. It is faster to choose Select All from the Edit menu, than it is to click on the selection
tool and drag a marquee around the whole map layer. This is particularly true if the map layer is larger than the viewing window.

The **Clipboard** has a design limit of 32 kilobytes for efficient cutting and pasting. It is recommended that the operations **Subscene** and **Cover** be used when fragments of map layers are greater than approximately 250 cells by 250 cells.

### Undoing Edits

Sometimes you will make a mistake while using the drawing tools or the editing commands. Fortunately MFworks comes equipped with an **Undo** command that allows you to undo the last change made to the map layer. If you realize that you really did want to make the change after all, MFworks allows a redo.

**Caution:** MFworks only supports one level of Undo/Redo if any additional edits are made to a map layer, it will not be possible to undo previous edits.

To undo the last edit to the Map window, choose **Undo** from the **File** menu.

To redo the last edit to the Map window, choose **Redo** from the **File** menu. As soon as the **Undo** command is used, it will be replaced in the **File** menu by the **Redo** command.